【EBS】「EC2: EBSスナップショットを作成」アクションで「InvalidSnapshotInUse:」エラーが出ます

エラーの原因

以下のようなエラーは、「EC2: EBSスナップショットを作成」アクションのジョブでEBSスナップショットの世代管理を行っている状態で、古い世代のEBSスナップショットの削除に失敗した場合に発生します。

InvalidSnapshotInUse: The snapshot snap-XXXXXXXX is currently in use by ami-XXXXXXXX

その原因は、「削除しようとしたEBSスナップショットがAMIから利用されている」ためです。

エラーの影響

「EC2: EBSスナップショットを作成」アクションのジョブで世代管理を設定している場合にこのエラーが発生すると、最も古い世代のEBSスナップショットが削除されずに残ってしまいます。

エラーの解消方法

これを解消するには、以下のいずれかの方法で対象のEBSスナップショットがAMIから利用されていない状態にします。

削除に失敗したEBSスナップショットおよびAMIが不要な場合

以下の手順で、AMIの登録解除を行ったうえでEBSスナップショットを削除してください。

  1. AWSマネジメントコンソールにサインインする
  2. EC2コンソールにアクセスする
  3. 「対象のEBSスナップショットを利用中のAMI」を登録解除する
  4. 「対象のEBSスナップショット」を削除する

削除に失敗したEBSスナップショットおよびAMIを残したい場合

以下の手順で、対象のEBSスナップショットを世代管理から外してください。

  1. AWSマネジメントコンソールにサインインする
  2. EC2コンソールにアクセスする
  3. 対象のEBSスナップショットに設定されている以下の2つのタグを取り除く
キー 値
Cloud Automator Snapshot Generation Cloud Automatorで管理されるスナップショットの世代管理番号
Cloud Automator Job ID Cloud Automatorで実行されるジョブID

 

この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています
他にご質問がございましたら、リクエストを送信してください